While I received Windows Vista Service Pack 1 (SP1) from Microsoft last Tuesday, I knew I wasn't going to be able to get much done during the past week because of a trip to Denver that was scheduled for Wednesday and Thursday. I was able to get SP1 installed on an HP Tablet PC, in time for the trip, mostly because it was recently purchased and still had the original (RTM) version of Vista installed. All of my other PCs had/have pre-release versions of SP1 installed, and the process for uninstalling that and reinstalling the final SP1 version is time consuming.

Well, as of Friday, I was back from Denver, so I started looking into getting my other PCs up to date with SP1. The biggest challenge would be my main desktop, Viiv (as in, "you haven't lived until you've viived"), because I intended to wipe it out and install Vista with SP1 from scratch. This was a challenge simply because it is my main desktop, and I keep my primary copies of a lot of data on there, including my Web sites, my music, photo, and video collections, and more. There was a lot of backing up to do and a lot of checking and rechecking.

Helping matters, Microsoft provided me with two SP1 discs. One includes both the x86 and x64 standalone installers, which can be used to upgrade existing Vista versions to SP1, and the other is an integrated Vista install disk that includes the SP1 bits built-in. I used the standalone installers on all the other systems, but I used the integrated full install on my main PC. Here's how it went.

Pre-wipeout: Backup, check everything, check everything again

Because of my need to test software on an ongoing basis, I tend to reinstall Windows repeatedly. This shouldn't be seen as a testimony to any weakness in Windows per se, it's just that I muck my systems up pretty quickly. There are two points to be made here: What I use changes pretty frequently, so I can't really automate the process very effectively. And I make some pretty standard mistakes each time I wipe out a system: Maybe I forget to deauthorize the system from iTunes, or fail to back up some saved games. It seems like I miss something every time.

This time, I wanted to make sure that didn't happen. And since I've changed the way I work over the past year, the process was made a bit easier this time around. The biggest change was getting my email, contacts, and calendar off the local system: I manage these in the Internet cloud, so to speak, using a variety of Google, Yahoo, Microsoft services. And not having to back up this stuff was a nice thing to not have to worry about.

But there was stuff on my PC that had to be backed up. The local version of the SuperSite, for example. My documents folder. My pictures. Saved games. Some work in progress from my desktop. I had to export my iTunes playlists and ratings so that I could reconstitute that data after reinstalling, but since the actual songs are stored on a removable HP Personal Media Drive (PMD), all I had to do there was detach the drive. That PMD also contains my movies and a few random backups. It was where I stored the stuff I backed up from the actual PC.

I also had to deauthorize my iTunes and Audible accounts. Decouple the PC from Windows Home Server. That kind of thing. I performed most of this work over the course of Saturday while doing other things in my office and around the home. I also made an additional copy of much of the backup to another external USB drive, just in case.

By Saturday night it was time to get to work.

Wipeout: Boot from the Vista install disk, install, cross fingers

Before installing Vista with SP1, I removed the PMD and unplugged all the non-necessary USB devices, or basically everything but my keyboard and mouse: This included the iPhone dock, the photo printer, the scanner, the Microsoft Xbox 360 game controller adapter, and a small Belkin USB hub. Stripped down to the basics, it was time to install.

Installing Vista, as you probably know, is a simple and quick-moving process. Installing Vista with SP1 is a virtually identical experience. After booting off the integrated DVD and answering a few questions about the how and where of the install, it was off and running, and the whole thing was mostly done in about 35 minutes. (One bit of trivia: There is one tiny difference in SP1 where the background image used during Setup is different from that used in the Setup routine for the RTM version of Vista. See the image below for a comparison.) At the end of Setup, you fill in some user account information, wait while it needlessly rates the performance of your system, and then logon to the desktop for the first time.

As with pre-SP1 versions of Vista, most hardware is simply installed correctly at first boot, and most of what wasn't installed by that point was quickly picked up automatically by Windows Update. I sort of short-circuited the process by manually installing the latest ATI video drivers, but that was all I had to do manually and I suspect that if I had waited, it would have done it all by itself. I then ran the Windows Experience Index (WEI) test to get that out of the way.

I left the USB stuff uninstalled for the time being and began installing my most necessary applications. The first round included Office 2007 Ultimate, Adobe Photoshop Elements 6.0, Microsoft Digital Image Suite 2006, ESET NOD32 (an antivirus solution I've been testing lately, though I usually use AVG Free), the Slysoft applications, Wakoopa Tracker, iTunes and QuickTime, the HP MediaSmart Home Server Connector, several Windows Live applications and services, and a few games, including Gears of War and Unreal Tournament 3. After plugging in the PMD, I also copied back some data, including my photo collection and documents.

Sunday morning, I revived all my iTunes playlists and ratings and began importing movies and fixing other iTunes-related miscellanea. Apple's digital media application works well if slowly, but it has a weird habit of dropping the same album art every time I copy the collection over, and I had to re-inform the application that certain videos were TV shows, not movies, one at a time, which I found laborious. It took a while, but iTunes was up and running pretty quickly, minus some podcasts, which I'll be downloading soon. Then it's on to the iPods, Apple TV, and iPhone, which will need to b resynched.

I also finished bringing over all the backed up data from the PMD on Sunday and installed a few things I'd forgotten, like Handbrake. I installed Vista's Web server and got my Web site back up and running, and made sure I could bring it up in Microsoft Visual Web Developer 2008 Express. Everything seemed to be working swimmingly, so I configured the networked laser printer and then brought up the USB devices one by one.

As I write this, the system is pretty much back the way it was. There are a few applications I'll need to install over time, like VMWare, and it will probably be tonight before I get to the iPods and iPhone. Those will take a long time. Other apps will come onboard as they're needed (like the Amazon MP3 downloader).

Installation triage

Through all this, Vista worked without a hitch, contrary to the horror stories that are so common online. There were no crashes, application or otherwise, and no errors. Explorer never hung, and my file transfers all seemed to run pretty smoothly. The only exception was an iTunes movie rental transfer, from the iPhone back to the PC, which took an unacceptably long time (I'm talking over 3 hours). I blame Apple for this, however. Despite claims to the contrary, iTunes isn't very well written. I like it, but it needs work.

Compared to the RTM version of Vista, which I first installed on this system back in late 2006, the SP1 install was just a bit smoother. More hardware was correctly configured automatically, and there were no post-install snafus, as there had been with Vista RTM. That said, Vista RTM didn't exactly fall down hard during my first install either. But there have been improvements.

To this date, I've now updated all of my Vista machines to SP1. My ongoing experiences with this release will shape my final review, of course, but after almost a week of steady use, I've got nothing but positive news. So far.