I’ve made a point of using nothing but the latest Windows 8 builds since late last year, and I moved from Developer Preview to Consumer Preview and then to Release Preview with relatively few issues. But there are two serious problems with the Windows 8 Release Preview that make me want to scream on a fairly regular basis. And while I won’t go running back to Windows 7 regardless, I bet either one of these would be enough to make others give up on this pre-release OS.

Hard crashes

The first is an issue I believe many are experiencing: You’re plugging along in Windows 8 with not a care in the world when—BAM!—application windows suddenly stop responding. You can move the mouse cursor around for a while, but once this has happened to you enough times you know the end game is inevitable: Eventually, the whole thing will just be unresponsive and you can CTRL + ALT + DEL until the sun comes up, but you’re never going to fix anything. Your only recourse? Hold down the Power button on your PC and watch all your work in progress get flushed down the toilet.

This problem may or may not be related to Internet Explorer, since IE seems to be involved in most of the crashes I’ve seen like this. But Windows Explorer is absolutely part of the problem. In fact, it’s one of the first things to go.

The weird part of this problem, perhaps, is its timing. I can go for days and never see it at all. But some mornings I’ll experience it five times before noon—this happened once while I was at TechEd, for example—and it’s beyond aggravating. It happened to me just this morning, actually, halfway through posting Windows Phone 7.5: Nokia Camera Extras. I had to reboot and start over from scratch. Grr…

Networking issue

The second of these issues is particularly strange and could admittedly be something odd with my home network configuration.

Sometimes, but not always, and often with large files for some reason, I’ll copy a file or group of files across my home network from my Windows 8 PC to my Windows Home Server 2011-based server. The file copy will chug along and then, suddenly, the transfer rate starts to drop and it keeps going until it hits zero. Oddly enough, if you just leave it sitting there, the file transfer actually does finish. But the file copy window never goes away, nor does it indicate completion.

foroncenotpentonsfault
I have to get used to the web just not working

OK, that’s weird enough. But once this happens, that PC (and only that PC) no longer works properly on the network. You can’t hit web sites, transfer more files, or do anything that requires the network. And this issue survives resetting the network connection, physically swapping the cable, rebooting the router, and … seriously … it even survives reboots.

nope

What basically happens is that nothing works for a while. And then, over time, it all comes back normally. Everything works, you think it’s fine. And then it happens again with no real warning.

It’s really strange.

Help me help Microsoft

To be clear, I’ve experienced both of these issues on multiple computers, though the second, networking-related issue has only occurred on my home network and, I believe, with desktop computers.

If anyone else is experiencing these issues, please do contact me immediately. I’d like to present these issues to Microsoft with a bit of backing, particularly for the second issue, which seems more like a poltergeist experience than a technical bug. But that’s what’s happening.

Update: Thanks to everyone that's written in. I'm about 250 emails into this so far and what's now clear is that these problems are both very real and very widespread. I've got a query in with Microsoft and will report back as soon as I can.