Sometime soon, Microsoft will finalize its Service Pack 1 (SP1) release for Windows 7 and Windows Server 2008 R2. Today, however, a near-final version of the service pack leaked online for both 32-bit (x86) and 64-bit (x64) versions of the OSes, and I took the time to install the build on my main Windows 7 desktop. As I write this, I'm installing it on two laptops as well.

(A bit of rumor-busting. Some sites have claimed that SP1 is complete and that Microsoft will release it to its OEM--i.e. PC maker--partners as soon as tomorrow. That is not the case. SP1 is imminent, but it's not quite done as I write this. It won't be long.)

So what is going on here?

While Service Pack 1 services both Windows 7 and Server 2008 R2, only the server side of things is getting a major upgrade with SP1. I'll write about that later, and it will require a fair bit of explanation because of some major functional changes.

For Windows 7, the picture is quite a bit simpler: There are no major new features coming with SP1. However, there are the following minor changes:

An updated version of Remote Desktop Services. This is required for a change that is coming in Server 2008 R2 with SP1 (RemoteFX).

Better support for third-party federation services. With this update, Windows 7 now supports services that utilize the WS-Federation passive profile protocol.

Improved HDMI audio device performance. SP1 fixes a bug in Windows 7 where a small percentage of users experienced a disruption of audio over HDMI after a reboot.

Minor XPS document fixes. For the rare case where an XPS document contains both portrait and landscape pages, SP1 fixes a bug that prevented correctly-formatted printing.

Hot-fixes and other bug fixes. Like any service pack, SP1 also contains an aggregation of previously released and new hot-fixes and other bug fixes.

As you can see, nothing major.

While final performance results will need to wait for the final release and for more PCs to be tested, I can report that the interactive SP1 install took about 44 minutes on my quad-core Core 2 Duo-based desktop. When Setup is complete and you're returned to the Windows desktop, winver and the System window both report that SP1 is installed. Winver reports it's at build 7601, where the final, RTM version of Windows 7 was build 7600.

Looking ahead, I'll of course report when SP1 is officially released. I'm wondering whether a Slipstreaming guide is in order. And of course I'll have a full review, for the Server side of the service pack.

Screenshots


Windows 7 Service Pack 1 interactive Setup.


Interactive Setup required ~40 minutes and one reboot.


Winver, post-install, indicates both SP1 and a new build number, 7601.


System window, post-install, reports that Service Pack 1 is applied.